Lost WIFI on PA-II

I called PurpleAir because my PA-II stopped reporting data and fell off about a month ago now. It powers on and stays on (as evidence by red light). I connected to alternative power sources just to test out and nothing. Now matter what I tried, and with call support (TRIED FOR DAYS TO FINALLY GET PHONE SUPPORT), the board will not connect to wifi and the PurpleAir hotspot will not turn on so that I can connect directly. I have not changed any wifi settings in over a year (I use Linksys Velop) and can confirm that even though the board is on it is not connecting to wifi. Something has happened that has caused the wifi to stop working. I can see the fans still spinning on the sensors when I plug power into it.

The utility isn’t working. I have installed it on my MacBook Pro (running latest MacOS) and my windows PC (running latest windows 10 version). I have installed the requisite USB drivers according to the utility. In both scenarios the Serial Port doesn’t show any USB connections. For the Mac it only shows two bluetooth connections unrelated to the PurpleAir. On the windows PC when you click the serial dropdown box there isn’t anything to select.


Hi @tampahoosier, I responded to your comment on the PurpleAir Utility post with something you can try. You can view the response here: The PurpleAir Utility - #4 by Ethan_Breinholt.

Thank you for responding, I use the cable all the time for other data connection devices.

For instance, my old GoPro Here Black 3. I use it to transfer video from it to my Mac and Windows PC. It works flawlessly.

You might want to try my solution to the same problem. I sent my PA II to PurpleAir in Utah to have them test my unit. Same red light working, but no WiFi generated. They discovered that my circuit board was damaged and the unit had to be replaced. It is unfortunate that replacement circuit boards are not available.
I now have a surge and brownout attachment on the outlet in my garage where I plug in my PA II to hopefully prevent this from happening again.
Good luck!

Hallo guys,
Same thing happened to me with PA-II, exactly the same. Nothing to do with it.
Had to buy another device :frowning_face: