PurpleAir won’t turn on

Hi!

I have a PurpleAir PA-II sensor which appears to no longer turn on. What troubleshooting steps can I take to resurrect it? Is there a hardware reset sequence, for example?

The sensor suddenly disappeared from the map yesterday morning. It can’t be seen on my home network. It isn’t broadcasting its own Wi-Fi network. And I can’t see any kind of indicator light or mechanical activity inside the housing.

I’ve tried unplugging and replugging it at both ends of the power cable. I’ve also plugged a different device into the same power outlet to verify power is available through the outlet.

Try and plug another USB cable from a wall charger/power brick into the PA-II sensor. This will help determine if the sensor is at fault or if it is the way power gets to the sensor. If it turns on, the power supply is the most likely culprit.

If it does not turn on, take a look at the power port, this will require some disassembly on your part. The power port is just a USB extension to power the board and there is a possibility that the power port cord is no longer functioning. Unplug the power port and plug in a USB cable that can provide power.

If the PA-II still doesn’t turn on, send us an email at contact@purpleair.com.