Sensor no longer shows on map

For a number of months, my outdoor sensor no longer shows up on the Purple Air map. In fact, most of the sensors in my development no longer show up. I’ve disconnected the Wi-Fi network that the sensor was connected to, then 30 minutes later reconnected that network. The Purple Air Wi-Fi network does not appear in my list of available Wi-Fi networks. When I try to connect to, the browser times out because it cannot locate that page. A few months ago, I purchased a new sensor to replace my old one, and the new one showed up on the map for a few weeks, but it’s now been gone since then. I followed the troubleshooting ideas listed, but no luck. I tried power cycling the sensor, but no luck - and yes, the red LED is on. I hope someone can give me some ideas. Thanks!

Hi Tom, can you email us at and provide the device IDs of the sensors in question? We’d like to take a look at them on our end.

Thanks for any help you can provide. I emailed the sensor i.d. I also turned off my router, waited 11 minutes, powered it back up, and I do not see the Purple Air Wi-Fi network listed.

Problem solved! It turned out to be an intermittent open circuit in the power cord. When I would move the sensor to look for the red LED, I was moving the cord enough that the connection was made and the light was on. But in the normal cord position, there was no light because there was no power. Duh. Sorry for causing you extra work for my bad cord.

1 Like