Trouble connecting with an Eero router

We come across a few reasons as to why the PurpleAir sensors will not connect to an Eero router. When the PurpleAir sensor and the Eero router want to use the same IP address, this can cause conflicts. Currently, we do not have a way of changing the IP address of the PurpleAir sensor but Eero does have a way to change the IP address to use an alternative.

The following explanation comes from:
networking - What happens if 2 devices want the same static IP address? - Super User.

If, for whatever reason, two or more network interfaces in a broadcast domain (aka subnet) respond to the same IP address, you will see serious network problems on all involved network interfaces.

This has the following reason: whenever a package arrives for the IP address in question the router asks the whole subnet “who has IP address foo?” and any network interface with IP address foo will answer. The answer contains the hardware address (aka MAC) of the network interface and will be written into the so-called ARP cache of the router for future (at least the next 5 minutes) use. So, whoever answers first will be the destination regardless of being the correct target of the specific package (which could have been requested by another network interface with the same IP address.

Option 1: Change to the Manual IP address on the Eero router.
This is the most common reason for the sensor not connecting

Within the Eero app:

  1. Navigate to “Network Settings” in the bottom right-hand corner.
  2. Select “DHCP & NAT”.
  3. Change the setting from Automatic to Manual IP and then select one of the three alternate options.
  4. Leave all of the other settings the same and select “Save” at the top. Your Eero will restart and your PurpleAir will be able to connect to it and appear on the PurpleAir map if the sensor has been successfully registered. All your other devices that know the network should connect back to your Eero router as well.

Option 2. Disable Frustration Free (if purchased on Amazon)

  1. Click on “Discover”, then Amazon Connected Home Frustration-Free Setup
  2. Click on Frustration-Free Setup
  3. Disable the Setting
  4. Connect the PurpleAir to the main Eero SSID network.
    View this post if you are trying to connect to a guest network.

Option 3. Advanced security settings.

  1. Turn off the advanced security of the Eero
  2. Do a hardware reset of the Eero unit connected to the Internet modem. This is what Eero Calls the Gateway Eero Pro. There is a small button in the back of the Eero unit you need to press until a yellow light comes on in front of the Eero. Keep pressing the button until the yellow light appears.
  3. Verify that the sensors reading appears on the PurpleAir map
  4. Then turn advanced security back on.

Learn More

Learn more about using captive portals.
Learn more about other reasons a sensor won’t connect to WiFi.
Learn more about using the PurpleAir Utility.

My PurpleAir Sensor connects to my Eero router without a problem.