Sensor is OFFLINE after successful registration

I have 1GB service through Metronet. I set up an old router with a 2G network. I have tested the 2G SSID and it works fine. I have successfully registered my sensor but then receive a message that it is offline. In looking at the footnotes it says that the default IP address for the sensor is That is the IP address for my eero gateway. Is that why why my sensor is offline. If so, what is the workaround? Changing my network to a different IP is not an option

Hi @greenter, we have heard of users having difficulties connecting their PurpleAir devices to Eero routers. I wonder if this could be the issue. We do not have an official solution, but a user has figured out a fix that I will share with you here. You may need to contact Eero if it does not work or you would not like to do it.

  1. Navigate to “Network Settings” in the Eero app
  2. Navigate to “DHCP & NAT”
  3. Switch to “Manual IP”

This will cause you to have to assign IP addresses on your router manually.

We have also heard of some users applying the following settings:

  • Subnet IP-
  • Subnet mask-
  • Starting IP-
  • Ending IP-

The user who sent this in had stated, “One thing to point out is that if a user already configured a static address for a particular device I believe they’ll need to manually change those to exist in the new IP range (this is done through the eero app as well, but probably good to remind folks.) They can check if they have any IP reservations by clicking on the Reservations & port forwarding setting on the Network Settings page.

That’s the only gotcha I can think of. It’s also possible that when the router comes back some devices may require a reboot to get their new IP from the router.”

A few users have also tried applying this fix, connecting the PurpleAir sensor, and then reverting the setting back to “Automatic.” I am not sure if this would work, but could also be worth a shot.

Hopefully, that helps, and our apologies for the inconvenience while we work towards a proper solution. If anyone has troubleshooting information they have done with Eero and making PurpleAir sensors connect to them, we would greatly appreciate it if you could contribute your knowledge.

Thank you for our response. Unfortunately I share the network does not belong to me and there are too many people who share the device. Looking through old posts it looks like this has been a problem for a while and I am surprised it hasn’t been resolved since eero units coming more into play. I should have done my homework on this one. I thought setting up the 2G network would be sufficient.

I had the same issue today on my Eero network after receiving my new PurpleAir sensor. I had to change the default eero network address from since my eero router was using as the default gateway…I switched my eero network over to and everything works fine now. PurpleAir needs to provide a way to change the default address in the sensor to something other than rather than forcing people to re-ip their entire network to get one device to work…

UPDATE - SUCCESS: It turned out that it was not big deal to change the IP.

Thank you. It turned out that everyone was okay with my changing the ip address. It worked perfectly. I did as suggested:

  1. Navigate to “Network Settings” in the eero app
  2. Navigate to “DHCP & NAT”
  3. Switch to “Manual IP”
    Note: I didn’t assign a new IP address - when set to manual it defaulted to 192.168.0… which was fine. I prefer to keep these settings and did not try to change back to Automatic.

I did find that the Eero allows you to temporarily pause 5G. Which was totally necessary to reconnect cameras, etc. To do this got to:

  1. Settings
  2. Troubleshooting
    3 My device won’t connect
  3. My device is 2.4 GHz only
  4. Temporarily pause 5 GHz
1 Like