Default AQI has changed to Candadian!

I’ve live in Bend/Central Oregon. Dealing with wildfire smoke once again, and have used PurpleAir for years. A few days ago, each time I open the air quality map, the index is Canadian AQHI, not the US AQI at the top of the list. I change it over and over, but it reverts to Canadian. Location services show me in my location. I followed the tip to zoom and pan, which should lock my chosen options as default, but that’s not happening. This is the first year in many that this has happened. Same computer as before. And thanks in advance for the help!

Are you using an old bookmark? You might need to set up the map the way you like then save a new bookmark.

Using a new bookmark, and it works fine when I open the page that way. But if I simply type in the page opens with the Canadian option. I’ve cleared cookies, but it still happens that way. Not a big deal. I will just use the bookmark. Does it on my phone, too. Location shows me where I live in Central Oregon, so it’s not that. Thanks for the help! I appreciate it!!!