PaymentRequiredError making api calls

Thanks Andrew - I will. In the meantime, can you explain why, when there is an error on your end, you are charging users API points? Will PurpleAir acknowledge that this is a bug, and fix it?

At this time, we’re eagerly looking to resolve this issue. We will be reimbursing points lost while we work on this.

Calls made to the API–even if they return an error–still consume API resources. Thus, moving forward after this issue is resolved, API calls will cost points for the designated API endpoint, even when receiving an error message. This is typical of API points systems.

We responded to your email. Please check there for further details about your API key and points.

1 Like

The issue should now be fixed. If anyone has the issue occur again, please let us know. If you see the PaymentRequiredError, make sure that you’ve moved your points from your Organization to your Project.

1 Like

Hi Andrew,
I’m experiencing the same issue.
I have transferred points to my project but my calls to the API are still throwing a payment required error. This is occurring for both my read and write keys; I have tried to get sensor data as well as create a group.
I will send an email to the email address you’ve mentioned, but I also wanted to document this here in case others are still running into issues.

1 Like

Update: I tried again both read and write calls about two days later and have had no issues. Looks like there still may be some lag recognizing the transfer of points, but once it was recognized in the system I have not had any further issues.


This may be the case. A number of changes have been implemented that should have resolved this issue for most users. That said, if any user continues to experience this issue, we’d like to hear about it.

Two issues:

a) I just realized that I needed to move my free 1,000,000 points from “Organization” to my “project”. Done. Should now allow me to spend about 400,000 points, assuming there is now a quick response to the back end from the website, but I still get the PaymentRequiredError.

b) On July 30, 2023 I paid $10.00 to Wepay/PurpleAir for more credits, but they have never showed up in my account. I emailed “” about that, but never received a reply.

Thanks for any support.

@Bill_Kowalik, please message me the email you used to contact us and we’ll help resolve the situation.

The email address is


I’ve removed the email in your comment for privacy, and sent an email to the provided address.

Hi, I used to download hourly PurpleAir data for 2021 over the CONUS for my research project with no issues. But I started to have issues yesterday, saying “Payment is required to make this api call.”. I added 1,000,000 points to my project and consumed it. It does not allow me to add more points to my organization/project anymore. Can anyone please help me? Should I pay for it?

Have you moved the points from your Organization to your Project? That may be the issue you’re running into. You can learn more here: New API Dashboard

Thanks, but There is 0 point in the organization.

Send an email to with your API key. We’ll take a look at the account and assist you further from there.

Sure, Thank you for the help.

1 Like

Hello, Andrew.
I forgot to say that I do not own any sensors and need PM_ATM for research purposes only.
I sent an email to the address you gave me but did not receive any help.
I need PM_ATM for all sensors in 2021 over the CONUS (preferably hourly data).
Can you please help me in this regard?

Hi Masoud, we responded to your email. Let me know if you haven’t received it.

Hi Andrew, Thanks. I received the email and replied it.